Jump to content

Compiling SystemC on ARM

Matthias Jung

Recommended Posts

Thanks for the feedback on how to make SystemC work on the aarch64 platform! At least another party has expressed its interest for support of this platform and offered patches, which are currently under review in the Language Working Group.



Link to comment
Share on other sites

  • 4 years later...

Hi Matthias,

Sorry for resurrecting this age old post :)

Wondering if you guys had tried compiling System-C recently on some of the recent MacBooks?  I tried your fix - but it still barfed in the configure script saying "configure: error: "sorry...architecture not supported"

I applied the fix to "sc_nbdefs.h" but wondering if I needed to apply these (and / or additional changes) elsewhere as well? Thanks in advance


Link to comment
Share on other sites

I compile on MacBook Pro (Apple Silicon M1max) without issue. I use cmake to build. I had to set the environment variable  CMAKE_APPLE_SILICON_PROCESSOR:


I have a script that pulls from the official accellera github and sets it all up to install under $HOME/.local/apps/systemc 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...