Jump to content

AmeyaVS

Members
  • Content Count

    181
  • Joined

  • Last visited

  • Days Won

    29

AmeyaVS last won the day on November 16 2020

AmeyaVS had the most liked content!

2 Followers

About AmeyaVS

  • Rank
    Advanced Member
  • Birthday 02/28/1989

Profile Information

  • Gender
    Not Telling
  • Location
    Bangalore

Contact Methods

  • Skype
    ameya.v.singh

Recent Profile Visitors

2,076 profile views
  1. Hello @Andy Goodrich, Thank you for the update. As also pointed out by @Paul Floyd in his post regarding Helgrind report here: Probably the Pthread threading constructs and implementation in SystemC needs to be looked into. Earlier also around the same time I reported the issue, I also did an analysis and found that the underlying constructs used in, pthread were updated. Something to do with futex updates for pthread in libc and the Linux Kernel. I don't have my notes now, since I have moved out. But one can probably look at differences in various system
  2. Hello @Andy Goodrich, Sorry for the delayed response. As per your suggestion removing the call to kill the thread. Let's the tests to completion without test failure. Regards, Ameya Vikram Singh
  3. Hello @Andy Goodrich, Here is the snippet of the log that is generated in my SystemC environment setup with pthreads enabled: SystemC 2.3.4_pub_rev_20191203-Accellera --- Jan 26 2021 22:27:50 Copyright (c) 1996-2019 by all Contributors, ALL RIGHTS RESERVED SystemC Simulation Warning: (W558) disable() or dont_initialize() called on process with no static sensitivity, it will be orphaned: top.target In file: ../src/sysc/kernel/sc_simcontext.cpp:771 Warning: (W558) disable() or dont_initialize() called on process with no static sensitivity, it will be orphaned:
  4. Hello @DavidA It might be if you are reusing the build directory and cmake has cached the previous configuration. What Generator backend are you using from cmake?(make/ninja or others) Regards, Ameya Vikram Singh
  5. Hello @DavidA It seems your SystemC library was built using C++11 standard. try changing the compile flag for the application to C++11 and see if this errors goes away. Regards, Ameya Vikram Singh
  6. Hello @DavidA Can you post the output of the following command: nm -C $SYSTEMC_HOME/lib/libsystemc.so | grep sc_api_version Regards Ameya Vikram Singh
  7. Hello @DavidA I don't see the "-std=c++14" in your application build command line. Regards, Ameya Vikram Singh
  8. Hello @Paul Floyd, Thank you for the confirmation. I did try out the valgrind tool with helgrind to understand the underlying threading issue. Even I came up to the same conclusion then, but I have lost the references to the underlying changes and discussions in the glibc posix_thread_* constructs. I did spend sometime looking into the issue and the internal implementation in SystemC library. But from what I could gather is that the usage of pthread_cond variable is somewhat inconsistent. As what I understand from earlier comments, people in the working groups pro
  9. Hello @Issraa, That good to hear. For completeness you can append at the end of the following file: ".bashrc" # SystemC Install path export SYSTEM_HOME=/home/israa/systemc export LD_LIBRARY_PATH=$SYSTEMC_HOME/lib-linux64 # If echo $LD_LIBRARY_PATH is not empty then the following #export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$SYSTEMC_HOME/lib-linux64 This will keep the configuration every time you open a new terminal. For reference: https://askubuntu.com/questions/58814/how-do-i-add-environment-variables Hope this helps. Regards, Ameya Vikram Singh
  10. Hello @Issraa, Can you post the output of the following command: ldd <your_executable_file> After setting the environment variable from the same terminal. Regards, Ameya Vikram Singh
  11. Hello @Issraa, Can you try setting the following environment variables: # Below statement are for bash shell modify the export command to be consistent with your shells configuration export SYSTEM_HOME=/home/israa/systemc export LD_LIBRARY_PATH=$SYSTEMC_HOME/lib-linux64 # If echo $LD_LIBRARY_PATH is not empty then the following export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$SYSTEMC_HOME/lib-linux64 And try again. Hope this helps. Regards, Ameya Vikram Singh
  12. Hello @Issraa, Have you shared the system root path list?(i.e. ls -al /) I want the content of the folder where the SystemC library was configured to be installed. ls -al /home/israa/systemc The system root will not really help. I would recommend you go through some UNIX/Linux system tutorial about the various shells and their configurations along with understanding various environment vairables. Hope this helps. Regards, Ameya Vikram Singh
  13. Hello @Issraa, Using default for configure script would probably generate the installation location to: /opt/systemc # or something similar. You would get error while trying to run the installation target if you don't have necessary privileges: make install Can you post the output you get on the terminal after running the previous command? Also, while setting the following environment variable: # Instead of this: export LD_LIBRARY_PATH=/home/israa/systemc-2.3.3/lib-linux64 # Can you try with this: export LD_LIBRARY_PATH=/opt/systemc/lib-linux64 Also, I would reco
  14. Hello @Issraa, It would be great if you could post the exact commands used. #For e.g. the configure command: # Did you use this ../configure #or this one ../configure --prefix=<some path for systemc installation> What is the output of the following command: make install Did it install the SystemC library without any issues? If yes. Try setting the following environment variables: # Below snippet compatible with bash shell export SYSTEMC_HOME=<path when the make install command copied the files> # If "echo $LD_LIBRARY_PATH" is not empty export LD_LIB
×
×
  • Create New...