Jump to content
Sign in to follow this  
diju.ms

Nested do in Questasim

Recommended Posts

I am using Cygwin to run my commands in a Windows system

So from bash prompt I am runnning the command.So Vsim opens in GUI mode and starts executing my script.

 

vsim -i -do "source my_script.tcl"

I am running a vsim command like this

vsim -novopt -assertdebug -sv_seed random -coverage -onfinish stop -c -do "echo $Sv_Seed; add wave -r /*; run -all; coverage save -onexit ./coverage_database/my_test$Sv_Seed.ucdb;" my_top -l ./sim_log/my_test$Sv_Seed.log +UVM_TESTNAME=my_test +UVM_VERBOSITY=UVM_LOW

But I am getting a message in questasim

 

Warning: Ignoring nested -do argument:

 

This is not taking the do commands in the vsim line.is there any option to solve this issue??

Share this post


Link to post
Share on other sites

You need to write your script as a script:

 

vsim -voptargs=+acc -assertdebug -sv_seed random -coverage -onfinish stop -c my_top -l ./sim_log/my_test$Sv_Seed.log +UVM_TESTNAME=my_test +UVM_VERBOSITY=UVM_LOW
add wave -r /*
run -all
coverage save -onexit ./coverage_database/my_test$Sv_Seed.ucdb;
There is no need to echo the seed - it does that for you automatically. You should use +acc instead of -novopt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...