Jump to content

Questasim: Problem with "paused" prompt

Recommended Posts

Hi there,

I'm facing a quiet annoying problem with my QuestaSim VHDL simulations.

I'm using the following construct in my testbenches to terminate simulations:

report "This is NOT an ERROR. This is the END of my simulation ..." severity failure;

To start my simulation, I run a simple .do script like:




run -all


puts "We're done!"



My problem is that the simulation "breaks" with the "failure" report statement and vsim is in the "paused" state afterwards. This means my macro (my run.do file) is "paused" at the "run -all" line and it won't execute the following statements. To continue the simulation (=execute the rest of the macro), I have to manually type "resume" in the GUI prompt.

The desired behavior for me would be the following:

In GUI mode: Run the full macro and ask if I really want tro exit simulation at the end.

In batch mode: Run the full macro and terminate/exit at the end.

I have already tried to find a solution using the "onfinish {...}" command but this didn't work.

My QuestaSim version: 10.0d (revison 2011/12).

Thank's a lot for your help!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...