Jump to content

UVM Factory override and compilation issue

Recommended Posts

Dear All,

I have an env that I am factory overriding with a new env called new_env. In new_env I have an agent called agent that doesn’t exist in env and is only instanced in new_env. In my test, that overrides env with new_env, I want to start a sequence on agent. Since new_env doesn't exist from the compilers point of view until the build_phase() (runtime) is done, the compiler errors due to the agent not existing.

How do I inform the compiler that new_env will exist once we're in runtime?


Link to comment
Share on other sites



- use the config_db so your sequencer starts the sequence you want

- start the sequence manually from the appropriate phase hooks inside new_env

- $cast your env to the new_env type if its a new_env, then start the sequence


Thanks Uwe! I tried your 3rd suggestion and it worked. Excellent!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...