Jump to content

Systemc2.3.4 doesnot generate a .a file?

Recommended Posts

I have been trying to use Systemc2.3.4 instead of 2.3.3. I have installed 2.3.4 and have run a small sample program which ran. I am currently testing out the example provided within "/systemc/examples/sysc/". Whenever I run make for any of these programs I am met with:

make: *** No rule to make target '/opt/systemc/lib/libsystemc.a', needed by '-----.x'.  Stop.

I have checked /opt/systemc/lib/ and there are only .so files present! Did I do something wrong in terms of the installation? or should I be doing some editing in the makefiles for these programs? 

I should also point out that "make check" had 0 fails when I run it after make command. And that log showed the target for simple_fifo.x was built and successfully tested. What am I missing?

Link to comment
Share on other sites

How did you install your SystemC?

  1. autotools (i.e., mkdir build && cd build && ../configure --prefix=INSTALLDIR && make && make install)
  2. cmake (i.e., cmake -B build; cmake --build build; cmake --install build)

Did you *carefully* read the install instructions (every point) or did you just rush through without comprehending what each step does?

What platform (i.e., machine), OS (i.e., Ubuntu, CentOS, macOS, mingw, ...), OS version #, and compilers (i.e., GCC, LLVM) are you using?

What new features of SystemC 2.3.4 are you attempting to exploit?

Have you considered adding the SystemC lib path to your LD_LIBRARY_PATH environment variable (to capture the .so files)?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...