Jump to content

Problem installing uvm-systemc library beta 3

Recommended Posts


I am trying to install uvm-systemc beta 3 library but when I run the configuration script I always get the same error:

configure: error: Non IEEE 1666 compatible SystemC version found, make sure that SystemC can be found and you build with the same compile options as building SystemC

I am using Ubuntu 18.04.1 LTS and GCC 7.5.0 both of which are marked as tested in the release notes. 

Does anybody know a possible cause for this error?

What parameters did you use for the configuration script?




Link to comment
Share on other sites

Hi all,

I found the problem. I was not aware the configure script compiles and runs a couple of small programs to perform some checks, since my installation path is not standard the linker wasn't able to find the libraries. The quick fix was to add systemc's lib directory to LD_LIBRARY_PATH.

Another thing that seemed to have caused problems was that initially I installed SystemC without architecture suffix, so the library directory was simply called lib. It was until I re-installed including the architecture suffix that uvm-systemc configuration script was happy. Perhaps there is a parameter to change this behaviour but I didn't try.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...