Jump to content
thundium

SystemC-2.3.0 regression failed due to link error under win+cygwin

Recommended Posts

Hi ALl:

 

My working environment is visual studio 2010 express + cygwin64.

I followed the READNE_windows.txt in the systemc regression release and did following steps.

 

SystemC unziped at c:\systemc-2.3.0

the regression at: C:\systemc_regressions-2.3.0

 

1. Opened systemc 2.3.0 msvc80 project and compiled (debug mode).

2. Visual studio command prompt (2010)

    - c:\cygwin64\Cygwin.bat

    - export SYSTEMC_HOME=/cygdrive/c/systemc-2.3.0

    - export CXX=cl

    - make a "run" under /cygdrive/c/systemc_regressions-2.3.0

    - and do "../scripts/verify.pl -g systemc" under the run

 

 

3. the perl script runs well, and I can see the setting prints are fine, like SYSTEMC_ARCH, SYSTEMC_HOME, TLM_HOME....

4. All test failed and when I check the log, I got

 

    cl : Command line warning D9035 : option 'GZ' has been deprecated and will be removed in a future release
    cl : Command line warning D9036 : use 'RTC1' instead of 'GZ'
    async_reset.cpp
    Unknown compiler version - please run the configure tests and report the results
    LINK: extra operand ‘/NODEFAULTLIB:LIBCD’
    Try 'LINK --help' for more information.

 

 

Anyone have run the regression before and have any idea for the that?

 

One thing I can think of is that the default VS dir is MSVC80 for SystemC while I am using MSVC10, systemc lib link failed? While I tried to compy msvc80 and renamed it to msvc10, still not working

Share this post


Link to post
Share on other sites

First of all: Yes, if you use MSVC 2010, you should rename/copy the msvc80 directory to msvc10 to allow enable the correct lookup of the SystemC.lib.  But you currently don't come to this point.

 

From the error message, it looks like you have the MSVC executable listed after the Cygwin command-line tools in your PATH environment variable.  Obviously, the Cygwin link.exe doesn't understand the options of the MSVC LINK.exe;)

 

hth,

Philipp

 

 

PS: You should use SystemC 2.3.1 to avoid the warning about the unsupported compiler version.  Secondly, a number of bugs have been fixed in this release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×