Jump to content

How to do coverage in UVM


Recommended Posts

Hi,

I done my coverage in uvm_monitor. i am running the test in vcs tool.

For coverage report I need simv.vdb file to run "urg" command.

i am using the following command :

urg -dir simv.vdb -report IndividualCovReport/test_name

urg -dir simv.vdb -format text -report IndividualCovReport/test_name

but i am getting following error :

Warning-[uRG-DNF] Directory not found

The directory 'simv.vdb' could not be found: No such file or directory.

Please verify all the directories given to the -dir option are valid.

Error-[uRG-ND] No source data

No source data was supplied to URG.

You may use options like '-dir', '-plan' or '-trend' to specify the source

data. Please run 'urg -help' for information.

Can anyone help me in this?

Please let me know how can I generate simv.vdb file?

Thanks

PS: I am using UVM ENV

Link to post
Share on other sites
  • 3 months later...
Guest joseph.steve

@ adil

You seem to be a spammer so that is why there is no logic in your post.So i will request to all that please do come here with a proper idea.

Link to post
Share on other sites
@ adil

You seem to be a spammer so that is why there is no logic in your post.So i will request to all that please do come here with a proper idea.

@joesef.stephen

The error messages indicate that there is an issue finding the simv.vdb when running urg command.

If the user has moved or has used -cm_dir <dir_name> then there will not be a simv.vdb and that will cause the error.

Thank you for looking out for Spammers, if you do find any real spammers then please alert me and I will remove them.

thanks.

adielkhan

Link to post
Share on other sites
  • 4 weeks later...

@joesef.stephen

The error messages indicate that there is an issue finding the simv.vdb when running urg command.

If the user has moved or has used -cm_dir <dir_name> then there will not be a simv.vdb and that will cause the error.

Thank you for looking out for Spammers, if you do find any real spammers then please alert me and I will remove them.

thanks.

adielkhan

But this is not the problem i checked. Actully when i run the test i am not getting the "simv.vdb" file at all. please help me in this.

And i am using the command -

urg -dir simv.vdb -report IndividualCovReport/$1

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...