Jump to content

SystemC Building Problems for Clang or Cmake. All test failing


Recommended Posts

Hello,

I wanted to build and install SystemC 2.3.3 on a Mac Catalania. I didn't called 'make install' yet due to the issue that 22 of 22 tests are failing.

I checked the logs of some of the test and saw in all files that a 'segmentation fault' got thrown before producing output.

While building it only throw 2 warnings see in the attachments.


My environment details:
OS: Mac Catalania 10.15.5
processor: intel i5 cmake found the type: __LP64__.

build tool tried: make GNU Make 3.81 and cmake 3.18.1
(Therefore it should not make a different that I didn't called gmake but make instead)
CXX = Apple clang version 11.0.3

in the attachment I copied the test-suit.log

For cmake build the test suit also throws segmentation faults.

What I found while ruining make for cmake, it thrown two errors in run_test.cmake
first line 104: string(REGEX REPLACE "^.*stopped by user.*$" "" RUN_TRIMMED_LOG ${RUN_LOG})
and line 108: string(REGEX REPLACE "^.*stopped by user.*$" "" EXPECTED_TRIMMED_LOG "${EXPECTED_LOG}")

message: 'string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
  command.'
Therefore I also post the 'LastTest.log to the attachment'

Did you experienced  this issue? Could you suggestions how to build it in a better way?
I also noticed that the install.md file for SystemC 2.3.3 has the version number systemc 2.3.2. Is this a problem?

Regards
Sören Kwasigroch

test-suite.log WarningsDuringBuild.rtf LastTest.log

Link to post
Share on other sites

Hey again,

I tested the tests from systemC 2.3.2 with the same environment.
Here only one test fails: 11 - examples/sysc/2.3/simple_async/simple_async (Failed)
for the makefile build and the cmake build.

Thats it's output:

Start SystemC

Fatal: (F4) assertion failed: sem_trywait == 0
In file: /Users/kwasigroch/Downloads/systemc-2.3.2/src/sysc/communication/sc_prim_channel.cpp:195

Info: (I99) simulation aborted

Expected is the output(golden.log): Here cmake copies a empty expected log file.

Start SystemC
I'm busy!
Asked to stop at time 10 ns

Info: /OSCI/SystemC: Simulation stopped by user.
The dog barks before the end of simulation
Program completed

 

Regards
Sören Kwasigroch

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...