Jump to content

'make package' does not find SystemC library


Recommended Posts

I am trying to assemble a package from my app. I builds and executes fine.

All other 'make XX' commands work OK, except that when I attempt 'make package', it throws the error message

CPackDeb: - Generating dependency list
CMake Error at /usr/share/cmake-3.10/Modules/CPackDeb.cmake:709 (message):
  CPackDeb: dpkg-shlibdeps: 'dpkg-shlibdeps: error: cannot find library
  libsystemc.so.2.3 needed by

I do have  libsystemc.so.2.3.3 in my /opt/systemc/lib, and have a libsystemc.so.2.3 to it.

The message comes from

        if(NOT SHLIBDEPS_RESULT EQUAL 0)
          message (FATAL_ERROR "CPackDeb: dpkg-shlibdeps: '${SHLIBDEPS_ERROR}';\n"

Given that during building and running everything works OK (i.e. the library found, I guess that it is in the right place), I have no idea whether it is my dust, or CMake/SystemC?

Maybe CPackDeb is looking for it on some other place?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...