Jump to content

[Help] An compile error encountered when I run the examples in "uvm-1.0p1"


Recommended Posts

Hi!

An compile error encountered when I run the examples in "uvm-1.0p1" as blow:

Error-[IWNMEE] `ifdef or `ifndef with no matching ../../../src/reg/uvm_reg_model.svh 32
`ifdef or `ifndef has no matching `else or `elseif or `endif, check that the directires are balanced.

:confused:

Could anyone tell me why? and how can i do?

Thanks a lot!

Link to post
Share on other sites

I can garantee you that the ifdef/endif are balanced in the UVM code... every vendor runs regressions continuously and such an error would have popped up.

You are not providing enough information to help you.

1- Which example?

2- What is yoru working directory?

3- What is your *complete* command line?

Link to post
Share on other sites
  • 3 months later...

Something else could be wrong, but it is not what the compiler tells you. I recently got this with VMM:

Error-[iWNMEE] `ifdef or `ifndef with no matching

file.sv, 19

`ifdef or `ifndef has no matching `else or `elsif or `endif.

Check that the directives are balanced.

Caused by this code like this:

`vmm_note(log,$psprintf(("%s",msg));

There are unbalanced parenthesis in the macro invocation, and the compiler gets confused. I can see the same kind of error in using UVM confusing the compiler in the same way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...