Jump to content

Error while installing systemc-2.3.0

Recommended Posts



I am installing systemc-2.3.0 package by following the steps given in INSTALL file in the package.


I am getting following error after "make" command.


Making all in src
make[1]: Entering directory `/root/Desktop/systemc-2.3.0/objdir/src'
Making all in sysc
make[2]: Entering directory `/root/Desktop/systemc-2.3.0/objdir/src/sysc'
Making all in kernel
make[3]: Entering directory `/root/Desktop/systemc-2.3.0/objdir/src/sysc/kernel'
/bin/sh ../../../libtool --tag=CXX   --mode=compile g++ -DSC_INCLUDE_FX   -I. -I../../../../src/sysc/kernel -I../../../../src   -Wall -m64  -O3 -pthread  -c -o sc_attribute.lo ../../../../src/sysc/kernel/sc_attribute.cpp
libtool: compile:  g++ -DSC_INCLUDE_FX -I. -I../../../../src/sysc/kernel -I../../../../src -Wall -m64 -O3 -pthread -c ../../../../src/sysc/kernel/sc_attribute.cpp  -o .libs/sc_attribute.o
../../../libtool: line 1153: g++: command not found
make[3]: *** [sc_attribute.lo] Error 1
make[3]: Leaving directory `/root/Desktop/systemc-2.3.0/objdir/src/sysc/kernel'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/Desktop/systemc-2.3.0/objdir/src/sysc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Desktop/systemc-2.3.0/objdir/src'
make: *** [all-recursive] Error 1


I am installing it on RHEL6.3.

version of gcc is 4.4.6 and have included it in objdir by "export CXX gcc" command.


Could anybody please help me out in solving this problem...




Link to post
Share on other sites
  • 2 weeks later...

The command should be


export CXX=g++


in a bash shell.


However there's a good chance g++ is in your path anyway - try


which g++


and see if it returns




or something like that. If it does, then you don't need to set CXX




Hello Alan


I tried "which g++" but, the o/p I got is:


/usr/bin/which: no g++ in (/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/root/bin)


Also, I tried the installation process again with


export CXX=g++


I am still getting the same error!! :(

Link to post
Share on other sites


There is a good possibility that the GCC compiler suite is not installed on

your machine. When we type in "which g++" on our machines we get:

$ which g++


To check if the GCC compiler suite is installed, just try at the command

prompt :

man g++

If correctly installed, the Linux/Unix man page for the GCC compiler

suite will be displayed. Otherwise there will an error message "No manual

entry found". Please note that the manual pages for the compiler suite

will get installed at the time the compiler suite gets installed.


Which RHEL are you using ? We used RHEL 5.x, and I clearly remember

that the person who did the OS installation asked us if we need the

standard Linux/Unix development tools to be installed as well. We now

use a combination of Fedora 14, 15 and 17.

So please ask your system administrator to install the GCC compiler


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...