Jump to content
Sign in to follow this  
mrforever

Problem when setting breakpoint using ucli

Recommended Posts

Hi, experts,

I want to set one breakpoint in the specific line in the specific file. But the ucli reports such an error:

 

ucli% stop -line 1371 -file uvm_reg_field.sv

Error-[uCLI-STOP-UNABLE-SET-STOP-POINT] Unable to set breakpoint

  The setting of line breakpoint in file uvm_reg_field.sv line 1371 due to 

  'stop' command was not successful. 

  Please verify that the 'stop' command arguments are valid and that the 

  statement/enclosing subprogram at file/line is used in the design.  If the 

  problem persists, please contact vcs_support@synopsys.com

 

Did anybody encounter such an error? Please help me.

Thanks in advance!

 

Regards

mrforever

Share this post


Link to post
Share on other sites

You might show the source code in question.  Looking at the copy of that file included with the version of VCS I'm using, that is a blank line.  Make sure your are setting your breakpoint on an executable line.

Share this post


Link to post
Share on other sites

hi,

Two basic things to check.

1) goto your preferences and make sure that you have enabled stopping in UVM library code. Most people dont debug the UVM library therefore breakpointing or stopping in it can be disabled or enabled as a preference.

 

2) ensure that the line you are trying to break on is procedural code and not declarative code. That is a class/variable definitions are declarative code, a function signature is declarative code. Whereas, code which "runs" like the contents of a loop is procedural code.

 

-adiel :rolleyes: 

Share this post


Link to post
Share on other sites

You might show the source code in question.  Looking at the copy of that file included with the version of VCS I'm using, that is a blank line.  Make sure your are setting your breakpoint on an executable line.

 

Hi logger,

 

I change line number from 1371 to 1372, the error still stays.

Share this post


Link to post
Share on other sites

hi,

Two basic things to check.

1) goto your preferences and make sure that you have enabled stopping in UVM library code. Most people dont debug the UVM library therefore breakpointing or stopping in it can be disabled or enabled as a preference.

 

2) ensure that the line you are trying to break on is procedural code and not declarative code. That is a class/variable definitions are declarative code, a function signature is declarative code. Whereas, code which "runs" like the contents of a loop is procedural code.

 

-adiel :rolleyes:

 

Hi adiel,

I have check the two points.

1) I cann't find any preferences about enabling stopping in UVM library code in ucli_ug.pdf, How can i add the preference in VCS or ucli?

2) The line i am trying to break on is procedural code.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...