Jump to content

Search the Community

Showing results for tags 'installation of system c'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Accellera Systems Initiative
    • Information
    • Announcements
    • In the News
  • SystemC
    • SystemC Language
    • SystemC AMS (Analog/Mixed-Signal)
    • SystemC TLM (Transaction-level Modeling)
    • SystemC Verification (UVM-SystemC, SCV, CRAVE, FC4SC)
    • SystemC CCI (Configuration, Control & Inspection)
    • SystemC Datatypes
  • UVM (Universal Verification Methodology)
    • UVM (IEEE 1800.2) - Methodology and BCL Forum
    • UVM SystemVerilog Discussions
    • UVM Simulator Specific Issues
    • UVM Commercial Announcements
    • UVM (Pre-IEEE) Methodology and BCL Forum
  • Portable Stimulus
    • Portable Stimulus Discussion
    • Portable Stimulus 2.0 Public Review Feedback
  • IP Security
    • SA-EDI Standard Discussion
    • IP Security Assurance Whitepaper Discussion
  • IP-XACT
    • IP-XACT Discussion
  • SystemRDL
    • SystemRDL Discussion
  • IEEE 1735/IP Encryption
    • IEEE 1735/IP Encryption Discussion
  • Commercial Announcements
    • Announcements

Categories

  • SystemC
  • UVM
  • UCIS
  • IEEE 1735/IP Encryption

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biography


Location


Interests


Occupation


Company

Found 2 results

  1. Hi, I tried to clone official SystemC repo from Accelera website and follow installation steps. After cloning and running autoconf I get the following error: configure.ac:58: warning: The macro `AC_CANONICAL_SYSTEM' is obsolete. configure.ac:58: You should run autoupdate. ./lib/autoconf/general.m4:2081: AC_CANONICAL_SYSTEM is expanded from... configure.ac:58: the top level configure.ac:565: warning: AC_OUTPUT should be used without arguments. configure.ac:565: You should run autoupdate. configure.ac:59: error: possibly undefined macro: AM_INIT_AUTOMAKE If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. configure.ac:117: error: possibly undefined macro: AM_PROG_AS configure.ac:270: error: possibly undefined macro: AC_PROG_LIBTOOL configure.ac:336: error: possibly undefined macro: AM_CONDITIONAL configure.ac:529: error: possibly undefined macro: AC_CHECK_DEFINE After running autoupdate (which finished w/o any message), I cannot configure, I get the error ../configure configure: error: cannot find required auxiliary files: install-sh And if I try to run autoconfig after autoupdate I get the similar error like before: If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. configure.ac:112: error: possibly undefined macro: AM_PROG_AS configure.ac:265: error: possibly undefined macro: AC_PROG_LIBTOOL configure.ac:331: error: possibly undefined macro: AM_CONDITIONAL configure.ac:524: error: possibly undefined macro: AC_CHECK_DEFINE Any hints on how can I fix this? Regards
  2. Dear all, I am new in the systemC world and I am trying to find a way through the set up. I would like to run systemC on Visual Studio 2013 Express. -Initially I download the systemc2.3.0 -Then I opened the ..\systemc-2.3.0\msvc80\SystemC.vcproj with Microsoft Visual Studio Express 2013 - At that point I got the following message: ---------------------------------------------------------------- "These projects are either not supported or need project behavior impacting modifications to open in this version of Visual Studio. Projects not displayed either require no changes or will automatically be modified such that behavior is not impacted. For details see: http://msdn.microsoft.com/query/dev12.query?appId=Dev12IDEF1&l=EN-US&k=k(VS.ReviewProjectAndSolutionChangesDialog.Upgrade)&rd=true One- way upgrade Visual studio will automatically make functional changes to the following projects in order to open them. You will not be able to open these projects in the version of Visual Studio in which they were originally created. " ---------------------------------------------------------------- - Then after pressing ok, I build the project and I get 12 Errors and 12 Warnings all stating the same thing: Warning C4005:'for': macro redefinition error C1189: #error : The C++ Standard Library forbids macroizing keywords. Enable warning C4005 to find the forbidden macro. Do anyone know how to solve this bug? I hope I can skip using Visual studio 2005. Thanks in advance!!!
×
×
  • Create New...