Jump to content


  • Content Count

  • Joined

  • Last visited

About marginasa

  • Rank

Recent Profile Visitors

334 profile views
  1. Hi Phillip, Actually I did not give a proper thought to this aspect, now that you mention it might make sense. I just followed the "general configure procedure" from linux.. But maybe for the sake of proper closure to this topic, is this a matter of efficiency of choosing between fibers and pthreads, because if there is, then the build process with pthreads should still work. I will check if it works without pthreads and post the result. Regards, Andrei
  2. Hi, For 2.3.1a revision: I modified line 33 of sc_cor_fiber.h as follows #if (defined(_WIN32) || defined(WIN32) || defined(WIN64)) && !defined(SC_USE_PTHREADS) The build process of the SystemC library succeeds. However there are issues when using the library during the link phase. -> make check fails. see attachment. make_check.log Note: I tried with this modification of the header file in the past also with GCC and it behaved the same as now. For 2.3.2 revision: the behavior is similar with 2.3.1a, that is, the compilation fails with the s
  3. Hi, After a debug session with Ameya (whom I thank), the build using clang was successful on cygwin but it still fails on MSYS2. Actually the build is failing with both GCC and clang compilers under MSYS2, each of them generating the same compiler error as mentioned in the first post. If anyone has a working MSYS environment in which it was able to build the systemc library, I'd like to have some confirmation. Regards, Andrei
  4. Hi Ameya, Actually with cygwin I get even earlier to a stop, as during the configure process it fails compile a C++ program. (but that may be related again to how complete is my cygwin environment). However within cygwin I manage to build the systemc library with the GCC chain which I'm able to use it, so I still have question marks regarding the reason for this cygwin:clang:configure:failToBuildC++ situation. see attachement. For Virtual Box solution I need more time to evaluate but I'll consider it. Thank you, Andrei config.log
  5. Hi Ameya, The path given to configure was indeed the Windows absolute path. I fixed that. Regarding MSYS2 setup I added some packages(that you mentioned autoconf, automake) and everything containing pthread that I could find but I see no meaningful difference in the way config.log looks like. However, this initial compiler error is independent in my opinion of the availability of the pthread lib. I attach the latest config.log and a list of my installed packages. Appreciate your help. Andrei config.log installed.packages
  6. Hi Ameya, Thank you for reply. I get the same error with using your configure options, when I execute make -j4 config.log and config.status are attached. Regards, Andrei config.log config.status
  7. Hi, I'm trying to build the systemc library using clang within MSYS $ clang -v clang version 3.9.1 (tags/RELEASE_391/final) Target: x86_64-w64-windows-gnu Thread model: posix InstalledDir: D:\Install\Msys2\mingw64\bin The configure options look as follows: ../configure --prefix=$SYSTEMC_LLVM --with-unix-layout CC=clang.exe CXX=clang++.exe CPP=`clang++.exe -E` CFLAGS=-stdlib=libstdc++ CXXFLAGS=-stdlib=libstdc++ CXXFLAGS=-std=c++11 LDFLAGS="-stdlib=libstdc++" --enable-pthreads --enable-debug The error I get is during compilation of sc_simcontext.cpp ...
  • Create New...