Jump to content
tommienator

SystemC 2.3.3 Msys2 and MinGW64 compile problem

Recommended Posts

Hey everyone,

I've successful compiled and installed the systemC library via Cygwin and was able to configure Eclipse so that it could compile my SystemC code by pointing it to the "include" and "lib-cygwin64" folder. Since I prefer to use Msys2 and MinGW64 I would like to compile the SystemC 2.3.3 library with, but it seems I don't get the same result. These are the commands that I put into MinGW64:

cd "path_to_systemC_lib"
mkdir objdir && cd objdir
../configure --enable-debug
make -j4
make check
make install

In Cygwin I put in the following commands (and works perfect):

cd "path_to_systemC_lib"
mkdir objdir && cd objdir
../configure --enable-debug --enable-pthreads
make check
make install

So, after the installation in MinGW64 is finished, I can't seem to find my "include" and "lib-what_the_name_can_be", what am I doing wrong here since I can't find any solutions online it seems for this problem? The reason for MinGW64 is so that I also can compile and install the scv library which doesn't support Cygwin. 

I've put the config file as an attachment, hopefully this can be helpful :)?

ps. tried it to compile on Linux, and worked (what did you expect) like a charm, but due to some .

config.log

Share this post


Link to post
Share on other sites

Your calls to the configure script don't include the option --prefix to specify the destination directory for installation. This is strongly recommended as the SystemC installation layout does not match well with the standard Unix directory layout for a conflict-free installation. Personally, I prefer to install SystemC on Unix-like platforms to /opt/systemc-2.3.3 (or similar). After make install, you can make sure that the include and lib-* directory below the prefix contains the necessary files. When building against this SystemC version, you will have to pass the proper include and linker flags. I recommend that you read the INSTALL and RELEASENOTES files, which are part of the SystemC PoC implementation. You may also consider to use the experimental CMake-based build system instead of the autotools.

Share this post


Link to post
Share on other sites
On 3/19/2019 at 9:03 AM, maehne said:

Your calls to the configure script don't include the option --prefix to specify the destination directory for installation. This is strongly recommended as the SystemC installation layout does not match well with the standard Unix directory layout for a conflict-free installation. Personally, I prefer to install SystemC on Unix-like platforms to /opt/systemc-2.3.3 (or similar). After make install, you can make sure that the include and lib-* directory below the prefix contains the necessary files. When building against this SystemC version, you will have to pass the proper include and linker flags. I recommend that you read the INSTALL and RELEASENOTES files, which are part of the SystemC PoC implementation. You may also consider to use the experimental CMake-based build system instead of the autotools.

Thanks for the response! Adding the --prefix="location" helped indeed resolve the problem :)! Normally I use it only in a Linux environment, but now there is no other possibility then running it on windows (unfortunately).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×