Jump to content

Recommended Posts

I build a constructor with the following {

tlm_utils::simple_initiator_socket<Init1> socket;

char buffer = A;
SC_THREAD(run);

}


run() {

        tlm::tlm_generic_payload trans;
        trans.set_command(TLM_READ_COMMAND);
        trans.set_data_ptr((unsigned char*)buffer);


        if ( trans.is_response_error() )
        {
          char txt[100];
          sprintf(txt, "Error from b_transport, response status = %s",
                  trans.get_response_string().c_str());
          SC_REPORT_ERROR("Error 1", txt);
        }

 

        socket->b_transport(trans, delay);

 

}

I usually got the error "TLM_INCOMPLETE_RESPONSE". Could you please support where can I find the issue?

Is the problem in the buffer?

Share this post


Link to post
Share on other sites

If you will read the SystemC standard, you will see that Initators are required to set the response initially to TLM_INCOMPLETE_RESPONSE. Targets are obliged to change this to either TLM_OK_RESPONSE or one of the valid error returns. Seems your downstream targets never saw the transaction. Perhaps the address decoding (in the interconnect) went wrong. You are obliged to set the command, address, data pointer, data length, streaming width, byte enable pointer, DMI hint and response. I suggest RTFM, then debug the interconnect andr targets for a receipt.

Share this post


Link to post
Share on other sites

You seem to be probing the transaction response, before driving your transaction :) Since the default transaction status is TLM_INCOMPLETE_RESPONSE, you are getting that message. 

Try moving the call to b_transport before checking the trans.is_response_error() ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×