Jump to content
Sign in to follow this  
SeanChou

[cadence] irun 10.20-s13 does not support uvm10p1?

Recommended Posts

1. in ubus example:

unix> irun –uvmhome $(uvm10p1_path) –sv +incdir+../sv ubus_tb_top.sv +UVM_TESTNAME=test_2m_4s

ncsim: *F,NOFDPI: function uvm_hdl_deposit not found in any of the shared object specified with –SV_LIB switch

2. another question:

In which version will IUS replace the embedded UVM (-uvm) code from EA to 10?

please help and thanks!

Edited by SeanChou

Share this post


Link to post
Share on other sites

Hi SeanChou,

Regarding #1 ,Please use the incisiv.10.20.015 , it works well for uvm10p1 example.

Regarding #2 ,As i know, incisiv.10.20.015 & UVC (VIPP92S06) are both based on EA.

Share this post


Link to post
Share on other sites

Hi SeanChou

UVM1.0p1 is supported from IES10.2s11 onwards, but you may need to compile an additional file on the command line in versions up to IES10.2s17

Try:

unix> irun –uvmhome $(uvm10p1_path) +incdir+../sv $(uvm10p1_path)/src/dpi/uvm_dpi.cc ubus_tb_top.sv +UVM_TESTNAME=test_2m_4s

Share this post


Link to post
Share on other sites

After double confirming, we found that IUS/1020_s15(hot fix) could works fine with the ubus example.

The main reason is that I forget to include dpi.cc in the script. Please forget it and thanks!

Share this post


Link to post
Share on other sites
1. in ubus example:

unix> irun –uvmhome $(uvm10p1_path) –sv +incdir+../sv ubus_tb_top.sv +UVM_TESTNAME=test_2m_4s

ncsim: *F,NOFDPI: function uvm_hdl_deposit not found in any of the shared object specified with –SV_LIB switch

2. another question:

In which version will IUS replace the embedded UVM (-uvm) code from EA to 10?

please help and thanks!

to run uvm-1.0p1 with an open source version you need to add "$uvmhome/src/dpi/uvm_dpi.cc" to the commandline. please note that for the ius 10.20s40+(=10.20s17) you dont need the *.cc on the commandline if you use the embedded uvm release.

/uwe

Share this post


Link to post
Share on other sites
Hi SeanChou,

Regarding #1 ,Please use the incisiv.10.20.015 , it works well for uvm10p1 example.

Regarding #2 ,As i know, incisiv.10.20.015 & UVC (VIPP92S06) are both based on EA.

UVC's as of today run with UVM10EA. UVM10EA is also the default when using '-uvm' which irun. if you want uvm10 you should add "-uvmhome `ncroot`/tool/uvm-1.0" to your cmdline

Share this post


Link to post
Share on other sites
For question 2, the upcoming June release should include the 1.0 version.

UVM10 is part of the March update release (10.20s40 sometimes also 10.20s17) - you dont need to wait till june

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×