Jump to content
Sign in to follow this  
Roman

Trouble running cadence-incisiv-10.20.010 with simple UVM example

Recommended Posts

Hi All,

I tried to run a simple UVM 1.0 example using cadence-incisiv-10.20.010.

there is INTERNAL EXCEPTION as below.

BTW, UVM 1.0 example can work well with ius-09.20.033.

i guess it's the DPI issue in -incisiv, dunno how to deal with it.

--------------------------------------------------------------------------------------------------------------------

--/uvm-1.0p1/examples/simple/hello_world]$ make --f Makefile.ius

irun -access rw -uvmhome ../../.. -uvmnoautocompile ../../../src/uvm.sv ../../../src/dpi/uvm_dpi.cc -define NCSIM +UVM_VERBOSITY=UVM_LOW -quiet -incdir . hello_world.sv

$CDSROOT = /_TOOLS_/dist/cadence-incisiv-/10.20.010/i686-pc-linux2.4

$TESTDIR = /home/uvm_rocoo/uvm-1.0p1/examples/simple/hello_world

TOOL: ncsc 10.20-p008

ncsc C++ parameters:

ncsc -COMPILER $CDSROOT/tools/systemc/gcc/4.4/bin/g++

-f ./INCA_libs/irun.lnx86.10.20.nc/ncsc_run/ncsc_obj/ncsc.args

-MANUAL

-CFLAGS "-DNCSC

-I$CDSROOT/tools/systemc/include_pch

-I$CDSROOT/tools/tbsc/include

-I$CDSROOT/tools/vic/include

-I$CDSROOT/tools/ovm/sc/src

-I$CDSROOT/tools/uvm/uvm_lib/uvm_sc/sc

-I$CDSROOT/tools/uvm/uvm_lib/uvm_ml/sc

-I$CDSROOT/tools/systemc/include/tlm2

-c

-x c++ -Wall

-I$CDSROOT/tools/include

-I$CDSROOT/tools/inca/include"

make[1]: Entering directory `/home/uvm_rocoo/uvm-1.0p1/examples/simple/hello_world'

ncsc: compiling $TESTDIR/../../../src/dpi/uvm_dpi.cc

make[1]: Leaving directory `/home/uvm_rocoo/uvm-1.0p1/examples/simple/hello_world'

make[1]: Entering directory `/home/uvm_rocoo/uvm-1.0p1/examples/simple/hello_world'

building library run.so

make[1]: Leaving directory `/home/uvm_rocoo/uvm-1.0p1/examples/simple/hello_world'

Top level design units:

uvm_pkg

hello_world

ncelab: *F,INTERR: INTERNAL EXCEPTION

-----------------------------------------------------------------

The tool has encountered an unexpected condition and must exit.

Contact Cadence Design Systems customer support about this

problem and provide enough information to help us reproduce it,

including the logfile that contains this error message.

TOOL: ncelab 10.20-p008

HOSTNAME: szx-13

OPERATING SYSTEM: Linux 2.6.18-164.11.1.el5 #1 SMP Wed Jan 6 13:26:04 EST 2010 x86_64

MESSAGE: cu_xcheck_proc_self - no PROC entry for VST_D_FUNCTION

-----------------------------------------------------------------

csi-ncelab - CSI TRIAL: Cadence Support Investigation, sending details to ncelab.err

csi-ncelab - CSI TRIAL: investigation complete, send ncelab.err to Cadence Support

irun: *E,ELBERR: Error during elaboration (status 255), exiting.

make: *** [run] Error 1

Share this post


Link to post
Share on other sites

hi,

please check your versions. UVM10 has been qualified for IUS10.2s11+ (and 9.2s35+) only. I see that you indicate to run with 10.2s10 but the version in the header shows 10.2p8.

regards

/uwe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×