Jump to content
matterser

SYSTEMC install 32bit on 64bit OS

Recommended Posts

Hi,

 

I want install systemc 32bit on my 64bit host.

 

I follow the website comment.

 cd $SYSTEMC_HOME/objdir
  ../configure --target=i686-linux-gnu

  # QuickThreads:
  make CPPFLAGS="-m32" AS="as --32"

  # Pthreads:
  make CPPFLAGS="-m32" QT_ARCH="pthreads" pthreads

  make install

But when I make CPPFLAGS="-m32" AS="as --32",

I have a problem, as following

make[3]: *** [libsystemc.la] Error 1
make[3]: Leaving directory `/root/systemc-2.3.1/src/sysc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/systemc-2.3.1/src/sysc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/systemc-2.3.1/src'
make: *** [all-recursive] Error 1

How can I solve the problem?

 

Thank a lot.

Share this post


Link to post
Share on other sites

Hi,

 

When I install 32bit systemc on 64bit OS,

# mkdir objdir
# cd objdir
# ../configure --prefix=/usr/local/systemc-2.3.1  --host=i686-linux-gnu
# make
# make install

And I have error:

/usr/local/systemc-2.3.1/lib-linux/libsystemc.a: could not read symbols: File in wrong format

Is that the enviroment problem?

 

Share this post


Link to post
Share on other sites

I could only compile with pthreads (quickthreads didn't work)

../configure  --host=i686-linux-gnu --prefix=/home/apf/systemc-2.3.1x86 --enable-pthreads

Then in my Makefile for the actual systemc program I was building, I had to add -m32 to g++

 

regards

Alan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×