Jump to content
Pruthvi015

Issue regarding Linux centos 6.5 i686 architecture

Recommended Posts

Hi all,

 

I'm facing problem in Centos i686 architecture .I'm installed Systemc-2.3.1 according to i686 architecture .It's compiling fine but while running it's giving segmentation Fault (core dumped) .Please tell me solution

 

Thanks,

Pruthvi

Share this post


Link to post
Share on other sites

Hi Ralph,

 

While am running same code in other architecture (X86_64) am not getting any error .If i run in I686 i'm getting following error

 

Program received signal SIGSEGV, Segmentation fault.
0x009d2033 in __memcpy_ssse3_rep () from /lib/libc.so.6
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.132.el6_5.2.i686 libgcc-4.4.7-4.el6.i686 libstdc++-4.4.7-4.el6.i686
(gdb)
 

 

Thanks,

Pruthvi

Share this post


Link to post
Share on other sites

Using the magic of Google...

 

There's a post here http://eab.abime.net/showthread.php?t=74226 which suggests it's SELINUX related, and suggests a possible work-around as follows:

Found a workarround.
This on terminal starts fs-uae correctly:
__GL_WRITE_TEXT_SECTION=0 fs-uae

And the relative documentation for it (/usr/share/doc/nvidia-340/html/openglenvvariables.html)
Disabling executable memory optimizations

By default, the NVIDIA driver will attempt to use optimizations which rely on being able to write to executable memory. This may cause problems in certain system configurations (e.g., on SELinux when the "allow_execmem" boolean is disabled or "deny_execmem" boolean is enabled, and on grsecurity kernels configured with CONFIG_PAX_MPROTECT). When possible, the driver will attempt to detect when it is running on an unsupported configuration and disable these optimizations automatically. If the __GL_WRITE_TEXT_SECTION environment variable is set to 0, the driver will unconditionally disable these optimizations.

Obviously replace fs-uae with the name of your SystemC executable,

 

regards

Alan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×