Jump to content
Sign in to follow this  
Hash

OSDLERROR Error :Hello world examples

Recommended Posts

Hello,

Iam trying to run the hello world from the Cadence UVM examples and could see this message as below

2)I dont see any issues in the UVM_REPORT, using NCSIM 11.10-s067 Version

Can anyone help me understand this?

-Thanks in advance

Hash

===========================================================================

"ncsim: *E,IMPDLL: Unable to load the implicit shared object.

OSDLERROR: /home/xyz/Cadence_Examples/uvm-1.1/uvm_lib/uvm_sv/examples/simple/hello_world/INCA_libs/worklib/hello_world/sv/_sv_export.so: cannot open shared object file: No such file or directory or file is not valid ELFCLASS32 library..

"

=========================================================================

==========================================================================

--- UVM Report catcher Summary ---

Number of demoted UVM_FATAL reports : 0

Number of demoted UVM_ERROR reports : 0

Number of demoted UVM_WARNING reports: 0

Number of caught UVM_FATAL reports : 0

Number of caught UVM_ERROR reports : 0

Number of caught UVM_WARNING reports : 0

--- UVM Report Summary ---

** Report counts by severity

UVM_INFO : 3

UVM_WARNING : 0

UVM_ERROR : 0

UVM_FATAL : 0

==========================================================================

Share this post


Link to post
Share on other sites

Hi Uwe

I am trying to run an example from /uvm-1.1/uvm_lib/uvm_sv/examples/simple/trivial under cadence installation

2)My command line is

////////////////////////////////

irun -uvm component.sv

////////////////////////////////

3)I could still see the issue as below

////////////////

ncsim: *E,IMPDLL: Unable to load the implicit shared object.

OSDLERROR: /home/xyz/Cadence_Examples/uvm-1.1/uvm_lib/uvm_sv/examples/simple/trivial/INCA_libs/worklib/test/sv/_sv_export.so: cannot open shared object file: No such file or directory or file is not valid ELFCLASS32 library..

ncsim> source /opt/cadence_11.10.067/installs/INCISIV111/tools/inca/files/ncsimrc

////////////////////////////////////////////////////////////////////////////////////////////

3)Can you comment on this?

-BR

Share this post


Link to post
Share on other sites

Hi Uwe,

Thank You

Yes, this is a broken install issue with the OS & fixed it !

Had an issue with some other test and with the cadence support documentation , got it fixed from IT

-BR

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×