Jump to content

Search the Community

Showing results for tags 'systemc 2.3.1'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Accellera Systems Initiative
    • Information
    • Announcements
    • In the News
  • SystemC
    • SystemC Language
    • SystemC AMS (Analog/Mixed-Signal)
    • SystemC TLM (Transaction-level Modeling)
    • SystemC Verification (UVM-SystemC, SCV)
    • SystemC CCI (Configuration, Control & Inspection)
    • SystemC Datatypes
  • UVM (Universal Verification Methodology)
    • UVM 2017 - Methodology and BCL Forum
    • UVM SystemVerilog Discussions
    • UVM Simulator Specific Issues
    • UVM Commercial Announcements
    • UVM (Pre-IEEE) Methodology and BCL Forum
    • UVM 1.2 Public Review
  • Portable Stimulus
    • Portable Stimulus Pre-Release Discussion
    • Portable Stimulus 1.0
  • IP-XACT
    • IP-XACT Discussion
  • IEEE 1735/IP Encryption
    • IEEE 1735/IP Encryption Discussion
  • OCP (Open Core Protocol)
  • UCIS (Unified Coverage Interoperability Standard)
  • Commercial Announcements
    • Announcements

Categories

  • SystemC
  • UVM
  • UCIS
  • IEEE 1735/IP Encryption

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biography


Location


Interests


Occupation


Company

Found 4 results

  1. Hi All, I just installed systemc 2.3.1 in windows 7.0 using cygwin64. I have also installed systemc-ams_2.0_beta1 I have compiled the exercise from Fraunhofer (comb_filter). this is the log: 15:48:17 **** Build of configuration Release for project test2 **** make all Building file: ../src/comb_filter.cpp Invoking: Cygwin C++ Compiler g++ -IC:/systemc-2.3.1/include -IC:/systemc-ams-2.0_beta1/include -IC:/TUV_AMS_Library/output/include/ -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/comb_filter.d" -MT"src/comb_filter.o" -o "src/comb_filter.o" "../src/comb_filter.cpp" In file included from C:/systemc-ams-2.0_beta1/include/systemc-ams:81:0, from C:/systemc-ams-2.0_beta1/include/systemc-ams.h:53, from ../src/comb_filter.cpp:17: C:/systemc-ams-2.0_beta1/include/scams/utility/data_types/sca_constants.h:52:21: warning: 'sca_util::SCA_UNDEFINED' defined but not used [-Wunused-variable] static const double SCA_UNDEFINED=std::numeric_limits<double>::max(); ^ Finished building: ../src/comb_filter.cpp Building file: ../src/dec_path_tb.cpp Invoking: Cygwin C++ Compiler g++ -IC:/systemc-2.3.1/include -IC:/systemc-ams-2.0_beta1/include -IC:/TUV_AMS_Library/output/include/ -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/dec_path_tb.d" -MT"src/dec_path_tb.o" -o "src/dec_path_tb.o" "../src/dec_path_tb.cpp" In file included from C:/systemc-ams-2.0_beta1/include/systemc-ams:81:0, from C:/systemc-ams-2.0_beta1/include/systemc-ams.h:53, from ../src/sin_src.h:17, from ../src/dec_path_tb.cpp:17: C:/systemc-ams-2.0_beta1/include/scams/utility/data_types/sca_constants.h:52:21: warning: 'sca_util::SCA_UNDEFINED' defined but not used [-Wunused-variable] static const double SCA_UNDEFINED=std::numeric_limits<double>::max(); ^ Finished building: ../src/dec_path_tb.cpp Building file: ../src/prefi.cpp Invoking: Cygwin C++ Compiler g++ -IC:/systemc-2.3.1/include -IC:/systemc-ams-2.0_beta1/include -IC:/TUV_AMS_Library/output/include/ -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/prefi.d" -MT"src/prefi.o" -o "src/prefi.o" "../src/prefi.cpp" In file included from C:/systemc-ams-2.0_beta1/include/systemc-ams:81:0, from C:/systemc-ams-2.0_beta1/include/systemc-ams.h:53, from ../src/prefi.h:17, from ../src/prefi.cpp:17: C:/systemc-ams-2.0_beta1/include/scams/utility/data_types/sca_constants.h:52:21: warning: 'sca_util::SCA_UNDEFINED' defined but not used [-Wunused-variable] static const double SCA_UNDEFINED=std::numeric_limits<double>::max(); ^ Finished building: ../src/prefi.cpp Building file: ../src/sadc.cpp Invoking: Cygwin C++ Compiler g++ -IC:/systemc-2.3.1/include -IC:/systemc-ams-2.0_beta1/include -IC:/TUV_AMS_Library/output/include/ -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/sadc.d" -MT"src/sadc.o" -o "src/sadc.o" "../src/sadc.cpp" In file included from C:/systemc-ams-2.0_beta1/include/systemc-ams:81:0, from C:/systemc-ams-2.0_beta1/include/systemc-ams.h:53, from ../src/sadc.h:21, from ../src/sadc.cpp:17: C:/systemc-ams-2.0_beta1/include/scams/utility/data_types/sca_constants.h:52:21: warning: 'sca_util::SCA_UNDEFINED' defined but not used [-Wunused-variable] static const double SCA_UNDEFINED=std::numeric_limits<double>::max(); ^ Finished building: ../src/sadc.cpp Building file: ../src/sin_src.cpp Invoking: Cygwin C++ Compiler g++ -IC:/systemc-2.3.1/include -IC:/systemc-ams-2.0_beta1/include -IC:/TUV_AMS_Library/output/include/ -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/sin_src.d" -MT"src/sin_src.o" -o "src/sin_src.o" "../src/sin_src.cpp" In file included from C:/systemc-ams-2.0_beta1/include/systemc-ams:81:0, from C:/systemc-ams-2.0_beta1/include/systemc-ams.h:53, from ../src/sin_src.h:17, from ../src/sin_src.cpp:17: C:/systemc-ams-2.0_beta1/include/scams/utility/data_types/sca_constants.h:52:21: warning: 'sca_util::SCA_UNDEFINED' defined but not used [-Wunused-variable] static const double SCA_UNDEFINED=std::numeric_limits<double>::max(); ^ Finished building: ../src/sin_src.cpp Building target: test2.exe Invoking: Cygwin C++ Linker g++ -LC:/systemc-2.3.1/lib-cygwin64 -LC:/systemc-ams-2.0_beta1/lib-cygwin -LC:/TUV_AMS_Library/output/lib -o "test2.exe" ./src/comb_filter.o ./src/dec_path_tb.o ./src/prefi.o ./src/sadc.o ./src/sin_src.o -lsystemc -lsystemc-ams -ltuv_ams_library Finished building target: test2.exe 15:48:35 Build Finished (took 18s.217ms) When I run test2.exe This is what I get: SystemC 2.3.1-Accellera --- Mar 15 2016 17:03:13 Copyright © 1996-2014 by all Contributors, ALL RIGHTS RESERVED SystemC AMS extensions 2.0 Version: 2.0_beta1 --- BuildRevision: 1739 20140531 Copyright © 2010-2014 by Fraunhofer-Gesellschaft Institut Integrated Circuits / EAS Licensed under the Apache License, Version 2.0 Info: SystemC-AMS: 4 SystemC-AMS modules instantiated 1 SystemC-AMS views created 4 SystemC-AMS synchronization objects/solvers instantiated Info: SystemC-AMS: 1 dataflow clusters instantiated cluster 0: 4 dataflow modules/solver, contains e.g. module: sin1 193 elements in schedule list, 64 us cluster period, ratio to lowest: 64 e.g. module: sin1 ratio to highest: 1 sample time e.g. module: dec1 0 connections to SystemC de, 1 connections from SystemC de The otuput file path_tb.dat is empty. It seems that the sc_mian is not reaching the return 0. I am using Eclipse Mars2 (Rel 4.5.2) as an IDE for C/C++ Does someone have had a similar issue?. Attached is the eclipse project. Thanks !. Alejandro test2.zip
  2. Hello All, I am trying to create a generic TLM interface for 2 to 3 modules . In which i am virtually inherting the tlm interface . But i am getting an error . Could you tell me the cause of error. example class A : public sc_module, public my_tlm_interface_fw{ }; class B : public sc_module, public my_tlm_interface_forward , public my_tlm_interface_backward{ } class C : public sc_module, public my_tlm_interface_backward{ } and binding C->initiator(B->target) B->initiator(A->target) Error: (E124) sc_export instance not bound to interface at end of construction: export 'i_top.tlm_base_initiator_socket_export_0' (sc_export) In file: ../../../../src/sysc/communication/sc_export.cpp:135
  3. Tamilselvan

    SystemC - Inconsistent result

    Hello all, I'm simulating MOESI protocol for L1 caches in SystemC. I'm getting different results for the same source code when running in SystemC 2.3.0 and SystemC 2.3.1 versions in different machines. Could anyone kindly pass some light on this topic? Machine1: Linux 3.13, Ubuntu 14.04, SystemC 2.3.1, Intel Pentium Dual Core processor. Output - Machine 1: CPU Reads RHit RMiss Writes WHit WMiss Hitrate 0 6 0 6 4 0 4 0.000000 1 34 0 34 22 0 22 0.000000 2 35 0 35 43 0 43 0.000000 3 39 2 37 46 2 44 4.705882 4 36 0 36 55 0 55 0.000000 5 52 0 52 47 0 47 0.000000 6 48 3 45 51 2 49 5.050505 7 42 1 41 55 5 50 6.185567 Total: 292 6 286 323 9 314 15 Avg: 36 0 35 40 1 39 1 2. Main memory access rates Bus had 286 reads and 1 upgrades and 314 readX. A total of 601 accesses. 3. Average time for bus acquisition There were 50 waits for the bus. Average waiting time per access: 0.083195 cycles. 4. There were 1 Cache to Cache transfers 5. Total execution time is 10204 ns, Avg per-mem-access time is 16.978369 ns 6. Probe Read: 5, Probe ReadX: 7 Machine 2: Linux 3.13, Ubuntu 14.04, SystemC 2.3.0, Intel i7 Quad Core processor. Output - Machine 2: CPU Reads RHit RMiss Writes WHit WMiss Hitrate 0 6 0 6 4 0 4 0.000000 1 34 0 34 22 0 22 0.000000 2 35 0 35 43 0 43 0.000000 3 39 2 37 46 2 44 4.705882 4 36 0 36 55 0 55 0.000000 5 52 0 52 47 0 47 0.000000 6 48 3 45 51 2 49 5.050505 7 42 1 41 55 5 50 6.185567 2. Main memory access rates Bus had 286 reads and 0 upgrades and 314 readX. A total of 600 accesses. 3. Average time for bus acquisition There were 51 waits for the bus. Average waiting time per access: 0.085000 cycles. 4. There were 0 Cache to Cache transfers 5. Total execu tion time is 10204 ns, Avg per-mem-access time is 17.006667 ns 6. Probe Read: 1 , Probe ReadX: 0 Does the version 2.3.0 and 2.3.1 are the reason for the inconsistent result? Source code and steps to run the simulation can be found here. Thanks, Tamilselvan Shanmugam.
  4. Hi Everyone - I had been trying to install and run a simple helloworld program using systemc 2.3.1, windows 8 and Visual Studio 2013. The library itself compiles fine. However, When i write a simple hello world program and builds it, it gives error "sprintf is unsafe. use sprintf_s. To disable deprecation, use _CRT_SECURE_NO_WARNINGS". After disabling it in the options. It started giving me 100's of link errors. I checked with the INSTALL guide of systemc 2.3.1, it only says supported on windows 7. Could this be the problem? Regards, Mustafa
×