Jump to content

Search the Community

Showing results for tags 'ebnf'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Accellera Systems Initiative
    • Information
    • Announcements
    • In the News
  • SystemC
    • SystemC Language
    • SystemC AMS (Analog/Mixed-Signal)
    • SystemC TLM (Transaction-level Modeling)
    • SystemC Verification (UVM-SystemC, SCV)
    • SystemC CCI (Configuration, Control & Inspection)
  • UVM (Universal Verification Methodology)
    • UVM 2017 - Methodology and BCL Forum
    • UVM SystemVerilog Discussions
    • UVM Simulator Specific Issues
    • UVM Commercial Announcements
    • UVM (Pre-IEEE) Methodology and BCL Forum
    • UVM 1.2 Public Review
  • Portable Stimulus
    • Portable Stimulus Discussion
  • IP-XACT
    • IP-XACT Discussion
  • IEEE 1735/IP Encryption
    • IEEE 1735/IP Encryption Discussion
  • OCP (Open Core Protocol)
  • UCIS (Unified Coverage Interoperability Standard)
  • Commercial Announcements
    • Announcements

Categories

  • SystemC
  • UVM
  • UCIS
  • IEEE 1735/IP Encryption

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biography


Location


Interests


Occupation


Company

Found 1 result

  1. Hi Forum I created a browsable grammar of the PSS formal syntax at http://insights.sigasi.com/tech/pss.ebnf.html#constant_expression The hyperlinks make it easier to explore and verify the grammar. Please let me know if you see any mistakes. While creating this, I also ran some validations, and found following issues: * Rule “activity_constraint_stmt”: 'constraint' should be styled as a keyword * There are two rules called “struct_type”, I assume the one in “B.9 Data types” is wrong. * Rule “exec_kind_identifier” is also duplicated. This is not an identifier, so I assume it should be renamed. * Rule “scheduling_constraint”: "," should be marked as keyword * Rule “constraint_declaration”: allow an optional trailing semicolon? (e.g. as in example Example 3—DSL: enum data type ) * “expression_constraint_item”: shouldn’t the implicand_constraint_item be optional? i.e. “expression [ implicand_constraint_item ] | ;” I also noticed a missing “}” in Example 3 (DSL: enum data type) Kind regards, Hendrik
×