Jump to content

Search the Community

Showing results for tags 'concatenation'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Accellera Systems Initiative
    • Information
    • Announcements
    • In the News
  • SystemC
    • SystemC Language
    • SystemC AMS (Analog/Mixed-Signal)
    • SystemC TLM (Transaction-level Modeling)
    • SystemC Verification (UVM-SystemC, SCV)
    • SystemC CCI (Configuration, Control & Inspection)
    • SystemC Datatypes
  • UVM (Universal Verification Methodology)
    • UVM 2017 - Methodology and BCL Forum
    • UVM SystemVerilog Discussions
    • UVM Simulator Specific Issues
    • UVM Commercial Announcements
    • UVM (Pre-IEEE) Methodology and BCL Forum
    • UVM 1.2 Public Review
  • Portable Stimulus
    • Portable Stimulus Pre-Release Discussion
    • Portable Stimulus 1.0
  • IP-XACT
    • IP-XACT Discussion
  • IEEE 1735/IP Encryption
    • IEEE 1735/IP Encryption Discussion
  • OCP (Open Core Protocol)
  • UCIS (Unified Coverage Interoperability Standard)
  • Commercial Announcements
    • Announcements

Categories

  • SystemC
  • UVM
  • UCIS
  • IEEE 1735/IP Encryption

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biography


Location


Interests


Occupation


Company

Found 1 result

  1. gsachin

    sc_signal concatenation

    Hi, I have a set of signals defined as: sc_signal<sc_logic> bit0; sc_signal<sc_logic> bit1; sc_signal<sc_logic> bit2; I have another buses defined as sc_signal<sc_bv<3> > bus_input; sc_signal<sc_bv<3> > bus_output; I would like to do this operation: bus_output = bit(i) & bus_input where i = 0,1,2 For this, I am writing this code: bus_output = (bit2.read(), bit1.read(), bit0.read()) & bus_input.read(); But this does not work. Compile is fine but only the bus_output[0] is correctly being written. other bits are not getting updated. Can you please let me know what is the issue? Thanks, Sachin
×