Jump to content

Search the Community

Showing results for tags 'Cygwin'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Accellera Systems Initiative
    • Information
    • Announcements
    • In the News
  • SystemC
    • SystemC Language
    • SystemC AMS (Analog/Mixed-Signal)
    • SystemC TLM (Transaction-level Modeling)
    • SystemC Verification (UVM-SystemC, SCV)
    • SystemC CCI Public Review
  • UVM (Universal Verification Methodology)
    • Methodology and BCL Forum
    • UVM SystemVerilog Discussions
    • Simulator Specific Issues
    • 1800.2-2017 Early Adopter Release
    • UVM Commercial Announcements
    • UVM 1.2 Public Review
  • Portable Stimulus
    • Portable Stimulus Discussion
    • IP-XACT Discussion
  • IEEE 1735/IP Encryption
    • IEEE 1735/IP Encryption Discussion
  • OCP (Open Core Protocol)
  • UCIS (Unified Coverage Interoperability Standard)
  • Commercial Announcements
    • Announcements


  • SystemC
  • UVM
  • UCIS
  • IEEE 1735/IP Encryption


  • Community Calendar

Found 3 results

  1. Hi all! I am having trouble importing UVM-SystemC library in Eclipse. It does not recognize any of the classes from that library. I installed uvm-systemc-1.0-alpha1 library and I am using Systemc-2.3.1 with Eclipse and Cygwin. When I try to write any of the code, for example: #include <uvm> class packet : public uvm_sequence_item{ }; It labels uvm_sequence_item red and says "Symbol 'uvm_sequence_item' could not be resolved". I added uvm-systemc in properties in library and added include paths to compiler settings in Eclipse.
  2. Hi all! I have a problem adding SCV library. I am new to SystemC! I am using 64bit Windows 7 and I have installed Cygwin x86_64. SystemC works with Eclipse but I am unable to add SCV library. When I try to execute $ ../configure --with-systemc=/cygwin/c/systemc-2.3.1 it writes out numerous lines and then I get errors checking for supported C++ compiler... configure: WARNING: gcc 5.4 is not a supported version (i.e. (3.2|3.4|4.1|4.2|4.3|4.4|4.5|4.6|4.7|4.8)). Beware. checking for supported operating system... configure: error: cygwin is not supported Is there any way to get around this problem?
  3. Hi, I am trying to run uvm code using qverilog command using shell script as : qverilog \ -timescale "1ns/1ns" \ -mfcu \ +acc=rmb \ +incdir+../../../../../src+../sv\ ../../../../../src/uvm.sv\ $TB_HOME/tb_top.sv \ -R \ -sv_lib ../../../../../win32/uvm_dpi -supress 2181\ +UVM_TESTNAME=$TEST_NAME\ -c \ -do "run -all; q" \ -l questa.log I get the error as : ** Error: ../../../../../src/uvm_pkg.sv(27): near "package": syntax error, unexpected IDENTIFIER, expecting class ./examples/tb_top.sv: line 1: ///*-----------------------------------------------------------------: No such file or directory ./examples/tb_top.sv: line 2: //File: No such file or directory Where starting lines of tb_top are commented, but it is expecting file names there. Please help. Regards, Chandan