Jump to content

zeno

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. Hi experts, (1) I downloaded vmm 1.2.2 and wanted to compile it by Questasim 10.0b, but there was an error during the compilation process as : # QuestaSim-64 vlog 10.0b Compiler 2011.05 May 5 2011 # ** Error: ../../../sv/std_lib/vmm.sv(4450): near "rst_typ": syntax error, unexpected IDENTIFIER, expecting :: # ** Error: gen.sv(4450): near "=": syntax error, unexpected '=', expecting class # ** Error: /Tools/linux/mentor/questasim10.0b/questasim/linux_x86_64/vlog failed. # Error in macro ./run_questa line 5 # /Tools/linux/mentor/questasim10.0b/questasim/linux_x86_64/vlog failed. # while executing (2) I also downloaded another Questasim compatible version of vmm 1.1 c from OVM world contribution website, and there was no error during compilation and loading process, but when I ran the test an error is shown as below: # ** Error: (vsim-8385) ../../../sv/std_lib/vmm_xactor.sv(26): fork..join_none statements in function 'new' only allowed if the calling process originates in an initial or always block. # ** Error: (vsim-8385) ../../../sv/std_lib/vmm_channel.sv(25): fork..join_none statements in function 'new' only allowed if the calling process originates in an initial or always block. Could anyone help me? Thank you in advance. BR zeno
×