Jump to content

Pruthvi015

Members
  • Content Count

    13
  • Joined

  • Last visited

About Pruthvi015

  • Rank
    Member
  • Birthday 07/22/1991

Profile Information

  • Gender
    Male

Recent Profile Visitors

272 profile views
  1. Hi Mark, Thanks for your replay. I checked the site .What i'm trying to reach is how much compatible Qemu if we are trying to modifies kernal(Here we are using MSM based gold fish kernal ) .I want to know the interface between these two(Qemu and kernal). Thanks Pruthvi Reddy
  2. Hi All, I'm new to virtual platform .What is the interface between Qemu and kernal(drivers )?? And how it's integrated ?? Could you please refer me documents or some stuff related to this ?? Thanks Pruthvi Reddy
  3. Hi all, Is their any available free source to interface TLM 2.0 to FLASH model (like AMBA to TLM 2.0)? Thanks, Pruthvi
  4. Pruthvi015

    Problem in TLM READ command

    Hi Alan, That i know i.e not following as per standard.(i tried in one way so it's getting as per my expectation) Second length i need always one.I changed the logic i.e uint8_t data=(0x01 & (bool)((device_rx_data[addr])& 0x1)). every time device_rx_data will be shifted by one as per the address. Now am transferring byte type and I'm getting same output (not my expectation) Thanks, Pruthvi
  5. Pruthvi015

    Problem in TLM READ command

    Hi all, if(cmd==tlm::TLM_READ_COMMAND){ flag=(bool)((device_rx_data[addr]>>len)& 0x1); data_ptr=reinterpret_cast<unsigned char*>(&flag); trans.set_data_ptr(reinterpret_cast<unsigned char*>(*data_ptr)); } Right now am getting correct values as per my need .But is this is correct path(setting again data_ptr ) ? Thanks, Pruthvi
  6. Pruthvi015

    Problem in TLM READ command

    Hi David, Thanks for technical details . I'm running under loop.How can i reuse the payload(I need serial transmission). Thanks, Pruthvi
  7. Pruthvi015

    Problem in TLM READ command

    Hi Alan, I'm typecasting bool to unsigned char(trans->set_data_ptr(reinterpret_cast<unsigned char*>(data)) data is bool type. And len will increase one every time(0 to 8) reading under loop.I did same thing in write command it's working fine. And i have to read bit by bit as per spec. Thanks, Pruthvi
  8. Pruthvi015

    Problem in TLM READ command

    Hi Alan, Thanks for replay. 1.I'm not using DMI(dmi_valid=false) 2.datatype of data is bool. 3.I'm reading bit by bit through b_transport. In TLM_READ_COMMAND){ bool flag=(bool)((device_rx_data[addr]>>len)& 0x1); data_ptr=reinterpret_cast<unsigned char*>(&flag); } Above code am converting byte to bit and am setting that bit address to data_ptr.(It is doing correctly as per my need by in other side i.e unsigned char* data_ptr=trans->get_data_ptr() is getting always zero ) Thanks, Pruthvi
  9. Pruthvi015

    Problem in TLM READ command

    Hi all, I'm getting problem in TLM read command .Please check the code once is am doing right ?Then why it's not reading correct value's? In read function.....i'm going through b_transport.... tlm::tlm_generic_payload* trans=new tlm::tlm_generic_payload; sc_time delay=sc_time(0,SC_NS); trans->set_command(tlm::TLM_READ_COMMAND); trans->set_address(addr); if((dmi_valid)&&(addr >=dmi_data.get_start_address()) && (addr<=dmi_data.get_end_address())){ SC_REPORT_INFO_VERB("Traffic_injector","dmi access",2); }else { SC_REPORT_INFO_VERB("traffic injector","READ:normal access....",2); trans->set_data_ptr(reinterpret_cast<unsigned char*>(data)); trans->set_data_length(length); trans->set_byte_enable_ptr(0); trans->set_response_status(tlm::TLM_INCOMPLETE_RESPONSE); initiator_socket->b_transport(*trans,delay); if(trans->is_response_error()){ SC_REPORT_ERROR("TLM-2","response error from b_transport"); } unsigned char* data_ptr=trans->get_data_ptr(); In b_transport .... tlm::tlm_command cmd=trans.get_command(); uint8_t addr=trans.get_address(); unsigned char* data_ptr=trans.get_data_ptr(); unsigned int len=trans.get_data_length(); if(cmd==tlm::TLM_READ_COMMAND){ bool flag=(bool)((device_rx_data[addr]>>len)& 0x1); data_ptr=reinterpret_cast<unsigned char*>(&flag); } In b_transport it setting correct values to data_ptr (as am checked in debugger).But in read unsigned char* data_ptr=trans->get_data_ptr(); am getting always zero...Is am doing right casting ?If not tell correct path? Thanks, Pruthvi
  10. Hi all, Is their any availability of NAND FLASH model in SystemC like verilog ?? Thanks , Pruthvi
  11. Pruthvi015

    Issue regarding Linux centos 6.5 i686 architecture

    Hi, I read the link and i try to solve the problem but am unable to solve the issue .Can you explain more ??? Thanks, Pruthvi
  12. Pruthvi015

    Issue regarding Linux centos 6.5 i686 architecture

    Hi Ralph, While am running same code in other architecture (X86_64) am not getting any error .If i run in I686 i'm getting following error Program received signal SIGSEGV, Segmentation fault. 0x009d2033 in __memcpy_ssse3_rep () from /lib/libc.so.6 Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.132.el6_5.2.i686 libgcc-4.4.7-4.el6.i686 libstdc++-4.4.7-4.el6.i686 (gdb) Thanks, Pruthvi
  13. Hi all, I'm facing problem in Centos i686 architecture .I'm installed Systemc-2.3.1 according to i686 architecture .It's compiling fine but while running it's giving segmentation Fault (core dumped) .Please tell me solution Thanks, Pruthvi
×