Jump to content

leitneth

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. Hi all, I'm facing an issue when using the UVMconnect package. The simulator complains about missing fields: # ** Error: (vsim-3567) /share/uvmc-2.2//src/connect/sv/uvmc_tlm1.sv(652): No field named 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm1_port_proxy::uvmc_tlm1_port_proxy__1 # ** Error: (vsim-3567) /share/uvmc-2.2//src/connect/sv/uvmc_tlm1.sv(652): No field named 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm1_port_proxy::uvmc_tlm1_port_proxy__1 # ** Error: (vsim-3043) /share/uvmc-2.2//src/connect/sv/uvmc_tlm1.sv(652): Unresolved reference to 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm1_port_proxy::uvmc_tlm1_port_proxy__1 # ** Error: (vsim-3567) /share/uvmc-2.2//src/connect/sv/uvmc_tlm2.sv(412): No field named 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm2_port_proxy::uvmc_tlm2_port_proxy__1 # ** Error: (vsim-3567) /share/uvmc-2.2//src/connect/sv/uvmc_tlm2.sv(412): No field named 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm2_port_proxy::uvmc_tlm2_port_proxy__1 # ** Error: (vsim-3043) /share/uvmc-2.2//src/connect/sv/uvmc_tlm2.sv(412): Unresolved reference to 'm_get_if_mask'. # Region: /uvmc_pkg::uvmc_tlm2_port_proxy::uvmc_tlm2_port_proxy__1 I have two connections in my desing, one TLM2 socket connection and one TLM1 analysis port connection. The SystemVerilog transaction item (my_item) has the packing methods implemented in the class, on SystemC side (my_sc_item) I use converter specialization for conversion. For example for the TLM2 connection, this is the code on SV side: uvm_tlm_b_initiator_socket #(my_item) initiator; initiator = new("initiator", this); uvmc_tlm #(my_item)::connect(initiator, "uvmc_channel"); And on SC side: tlm_utils::passthrough_target_socket<module, 32, my_sc_item> target; uvmc::uvmc_connect(target, "uvmc_channel"); I used UVMconnect successfully before, thus I wonder what's wrong in this case. Any idea where those errors comes from? Thanks, Thomas
×